$re = '/3[7-9]|[4-9]\d+|[1-9]\d{2,}/';
$str = 'Items 1 to 36 of 605 total
Items 1 to 36 of 117 total
Items 1 to 36 of 74 total
37
38
39';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);