import Foundation
let pattern = #"3[7-9]|[4-9]\d+|[1-9]\d{2,}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Items 1 to 36 of 605 total
Items 1 to 36 of 117 total
Items 1 to 36 of 74 total
37
38
39
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)