re = /3[7-9]|[4-9]\d+|[1-9]\d{2,}/
str = 'Items 1 to 36 of 605 total
Items 1 to 36 of 117 total
Items 1 to 36 of 74 total
37
38
39'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end