import re
regex = re.compile(r"3[7-9]|[4-9]\d+|[1-9]\d{2,}")
test_str = ("Items 1 to 36 of 605 total\n"
"Items 1 to 36 of 117 total\n"
"Items 1 to 36 of 74 total\n\n"
"37\n"
"38\n"
"39")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")