# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([^\W_]+)(?:_[^\W_]+)*_([^\W_])[^\W_]*$/\1_\2/gm;t' <<< "Thomas_J_Perkins
Jennifer_Scanner
Amanda_K_Loso
Aaron_Cole
Mark_L_Lamb"