re = /^([^\W_]+)(?:_[^\W_]+)*_([^\W_])[^\W_]*$/m
str = 'Thomas_J_Perkins
Jennifer_Scanner
Amanda_K_Loso
Aaron_Cole
Mark_L_Lamb'
subst = '\\1_\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result