const regex = /^([^\W_]+)(?:_[^\W_]+)*_([^\W_])[^\W_]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^\\W_]+)(?:_[^\\W_]+)*_([^\\W_])[^\\W_]*$', 'gm')
const str = `Thomas_J_Perkins
Jennifer_Scanner
Amanda_K_Loso
Aaron_Cole
Mark_L_Lamb`;
const subst = `\1_\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);