import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^\\W_]+)(?:_[^\\W_]+)*_([^\\W_])[^\\W_]*$";
final String string = "Thomas_J_Perkins\n\n"
+ "Jennifer_Scanner\n\n"
+ "Amanda_K_Loso\n\n"
+ "Aaron_Cole\n\n"
+ "Mark_L_Lamb";
final String subst = "\\1_\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}