use strict;
my $str = 'Thomas_J_Perkins
Jennifer_Scanner
Amanda_K_Loso
Aaron_Cole
Mark_L_Lamb';
my $regex = qr/^([^\W_]+)(?:_[^\W_]+)*_([^\W_])[^\W_]*$/mp;
my $subst = '\\1_\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";