# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([^\W_]+)(?:_[^\W_]+)*_([^\W_])[^\W_]*$"
test_str = ("Thomas_J_Perkins\n\n"
"Jennifer_Scanner\n\n"
"Amanda_K_Loso\n\n"
"Aaron_Cole\n\n"
"Mark_L_Lamb")
subst = "\\1_\\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.