# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<![^|])0+\.0+(?![^|])/0.0/gm;t' <<< "4|5|0.00000000|"