const regex = new RegExp('(?<![^|])0+\\.0+(?![^|])', 'gm')
const str = `4|5|0.00000000|`;
const subst = `0.0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);