import Foundation
let pattern = #"(?<![^|])0+\.0+(?![^|])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"4|5|0.00000000|"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"0.0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)