$re = '/(?<![^|])0+\.0+(?![^|])/m';
$str = '4|5|0.00000000|';
$subst = "0.0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;