import re
regex = re.compile(r"(?<![^|])0+\.0+(?![^|])", flags=re.MULTILINE)
test_str = "4|5|0.00000000|"
subst = "0.0"
result = regex.sub(subst, test_str)
if result:
print(result)