use strict;
my $str = '4|5|0.00000000|';
my $regex = qr/(?<![^|])0+\.0+(?![^|])/mp;
my $subst = '0.0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";