#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(?<=\<strong>)([0-9]+)(?=\s*<\/strong>)"
Local $sString = "There are <strong>54</strong> 12cities" & @CRLF & _
"There are <strong>54 wee wee we</sstrong> 12cities" & @CRLF & _
"There are <strong>54</stron2g> 12cities" & @CRLF & _
"There are <strong>5433d</strong> 12cities" & @CRLF & _
"There are <strong>54 </strong> 12cities" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")