import Foundation
let pattern = #"(?<=\<strong>)([0-9]+)(?=\s*<\/strong>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
There are <strong>54</strong> 12cities
There are <strong>54 wee wee we</sstrong> 12cities
There are <strong>54</stron2g> 12cities
There are <strong>5433d</strong> 12cities
There are <strong>54 </strong> 12cities
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)