re = /(?<=\<strong>)([0-9]+)(?=\s*<\/strong>)/im
str = 'There are <strong>54</strong> 12cities
There are <strong>54 wee wee we</sstrong> 12cities
There are <strong>54</stron2g> 12cities
There are <strong>5433d</strong> 12cities
There are <strong>54 </strong> 12cities
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end