$re = '/(?<=\<strong>)([0-9]+)(?=\s*<\/strong>)/im';
$str = 'There are <strong>54</strong> 12cities
There are <strong>54 wee wee we</sstrong> 12cities
There are <strong>54</stron2g> 12cities
There are <strong>5433d</strong> 12cities
There are <strong>54 </strong> 12cities
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);