const regex = /(?<=\<strong>)([0-9]+)(?=\s*<\/strong>)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\<strong>)([0-9]+)(?=\\s*<\\\/strong>)', 'gim')
const str = `There are <strong>54</strong> 12cities
There are <strong>54 wee wee we</sstrong> 12cities
There are <strong>54</stron2g> 12cities
There are <strong>5433d</strong> 12cities
There are <strong>54 </strong> 12cities
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}