using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#(\d+)#\s+(\d{4}-\d{2}-\d{2})T(\d{2}:\d{2}:\d{2})-(\d{2}:\d{2})\s+(\S+)\s+(\S+)\s+(.*)\.* task ""(.*)""\s.* ""(.*)""\s.*action ""(.+)""\s+.*\s+return\s+code\s+(\d+)\.";
string input = @"#134# 2015-05-14T21:22:40-04:00 PRODNJ-RPT01 Microsoft-Windows-TaskScheduler Task Scheduler successfully completed task ""\WarmUp Vantage"" , instance ""{E26D061B-15DD-4F58-B80C-4F11225333DF}"" , action ""D:\warmupscrt\BSAImpersonationIssueFixer.exe"" with return code 0.";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}