use strict;
my $str = '#134# 2015-05-14T21:22:40-04:00 PRODNJ-RPT01 Microsoft-Windows-TaskScheduler Task Scheduler successfully completed task "\\WarmUp Vantage" , instance "{E26D061B-15DD-4F58-B80C-4F11225333DF}" , action "D:\\warmupscrt\\BSAImpersonationIssueFixer.exe" with return code 0.';
my $regex = qr/#(\d+)#\s+(\d{4}-\d{2}-\d{2})T(\d{2}:\d{2}:\d{2})-(\d{2}:\d{2})\s+(\S+)\s+(\S+)\s+(.*)\.* task "(.*)"\s.* "(.*)"\s.*action "(.+)"\s+.*\s+return\s+code\s+(\d+)\./p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}