import re
regex = re.compile(r"#(\d+)#\s+(\d{4}-\d{2}-\d{2})T(\d{2}:\d{2}:\d{2})-(\d{2}:\d{2})\s+(\S+)\s+(\S+)\s+(.*)\.* task \"(.*)\"\s.* \"(.*)\"\s.*action \"(.+)\"\s+.*\s+return\s+code\s+(\d+)\.")
test_str = "#134# 2015-05-14T21:22:40-04:00 PRODNJ-RPT01 Microsoft-Windows-TaskScheduler Task Scheduler successfully completed task \"\\WarmUp Vantage\" , instance \"{E26D061B-15DD-4F58-B80C-4F11225333DF}\" , action \"D:\\warmupscrt\\BSAImpersonationIssueFixer.exe\" with return code 0."
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")