import Foundation
let pattern = ##"#(\d+)#\s+(\d{4}-\d{2}-\d{2})T(\d{2}:\d{2}:\d{2})-(\d{2}:\d{2})\s+(\S+)\s+(\S+)\s+(.*)\.* task "(.*)"\s.* "(.*)"\s.*action "(.+)"\s+.*\s+return\s+code\s+(\d+)\."##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"#134# 2015-05-14T21:22:40-04:00 PRODNJ-RPT01 Microsoft-Windows-TaskScheduler Task Scheduler successfully completed task "\WarmUp Vantage" , instance "{E26D061B-15DD-4F58-B80C-4F11225333DF}" , action "D:\warmupscrt\BSAImpersonationIssueFixer.exe" with return code 0."##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}