import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#(\\d+)#\\s+(\\d{4}-\\d{2}-\\d{2})T(\\d{2}:\\d{2}:\\d{2})-(\\d{2}:\\d{2})\\s+(\\S+)\\s+(\\S+)\\s+(.*)\\.* task \"(.*)\"\\s.* \"(.*)\"\\s.*action \"(.+)\"\\s+.*\\s+return\\s+code\\s+(\\d+)\\.";
final String string = "#134# 2015-05-14T21:22:40-04:00 PRODNJ-RPT01 Microsoft-Windows-TaskScheduler Task Scheduler successfully completed task \"\\WarmUp Vantage\" , instance \"{E26D061B-15DD-4F58-B80C-4F11225333DF}\" , action \"D:\\warmupscrt\\BSAImpersonationIssueFixer.exe\" with return code 0.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}