#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)cpe:2\.3:[aho](?::(?:[a-zA-Z0-9!"#$%&'()*+,\\\-_.\/;<=>?@\[\]^`{|}~]|\\:)+){10}$"
Local $sString = "cpe:2.3:a:1024cms:1024_cms:1.4.1:*:*:*:*:*:*:*" & @CRLF & _
"cpe:2.3:a:alawar:motor_town\:_machine_soul_free:1.1:*:*:*:*:android:*:*" & @CRLF & _
"cpe:2.3:a:lemonldap-ng:lemonldap\:\::0.6:*:*:*:*:*:*:*" & @CRLF & _
"cpe:2.3:a::::::::::" & @CRLF & _
"cpe:2.3:a:vendor:product:version:update:edition:lang:sw_edition:target_sw:target_hw:other:bla:bla:bla:bla:bla"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")