const regex = /cpe:2\.3:[aho](?::(?:[a-zA-Z0-9!"#$%&'()*+,\\\-_.\/;<=>?@\[\]^`{|}~]|\\:)+){10}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('cpe:2\\.3:[aho](?::(?:[a-zA-Z0-9!"#$%&\'()*+,\\\\\\-_.\\\/;<=>?@\\[\\]^`{|}~]|\\\\:)+){10}$', 'gm')
const str = `cpe:2.3:a:1024cms:1024_cms:1.4.1:*:*:*:*:*:*:*
cpe:2.3:a:alawar:motor_town\\:_machine_soul_free:1.1:*:*:*:*:android:*:*
cpe:2.3:a:lemonldap-ng:lemonldap\\:\\::0.6:*:*:*:*:*:*:*
cpe:2.3:a::::::::::
cpe:2.3:a:vendor:product:version:update:edition:lang:sw_edition:target_sw:target_hw:other:bla:bla:bla:bla:bla`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}