import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "cpe:2\\.3:[aho](?::(?:[a-zA-Z0-9!\"#$%&'()*+,\\\\\\-_.\\/;<=>?@\\[\\]^`\\{|\\}~]|\\\\:)+){10}$";
final String string = "cpe:2.3:a:1024cms:1024_cms:1.4.1:*:*:*:*:*:*:*\n"
+ "cpe:2.3:a:alawar:motor_town\\:_machine_soul_free:1.1:*:*:*:*:android:*:*\n"
+ "cpe:2.3:a:lemonldap-ng:lemonldap\\:\\::0.6:*:*:*:*:*:*:*\n"
+ "cpe:2.3:a::::::::::\n"
+ "cpe:2.3:a:vendor:product:version:update:edition:lang:sw_edition:target_sw:target_hw:other:bla:bla:bla:bla:bla";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}