#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\.com\/(?:pages\/)?([\w-]+)"
Local $sString = "https://www.facebook.com/abc-def-12345678/" & @CRLF & _
"" & @CRLF & _
"https://www.facebook.com/audi" & @CRLF & _
"" & @CRLF & _
"https://www.facebook.com/pages/abc-def/1234568" & @CRLF & _
"" & @CRLF & _
"https://www.facebook.com/audi/timeline?ref=page_internal"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")