use strict;
my $str = 'https://www.facebook.com/abc-def-12345678/
https://www.facebook.com/audi
https://www.facebook.com/pages/abc-def/1234568
https://www.facebook.com/audi/timeline?ref=page_internal';
my $regex = qr/\.com\/(?:pages\/)?([\w-]+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}