import Foundation
let pattern = #"\.com\/(?:pages\/)?([\w-]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
https://www.facebook.com/abc-def-12345678/
https://www.facebook.com/audi
https://www.facebook.com/pages/abc-def/1234568
https://www.facebook.com/audi/timeline?ref=page_internal
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)