// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\.com\/(?:pages\/)?([\w-]+)").unwrap();
let string = "https://www.facebook.com/abc-def-12345678/
https://www.facebook.com/audi
https://www.facebook.com/pages/abc-def/1234568
https://www.facebook.com/audi/timeline?ref=page_internal";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}