package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\.com\/(?:pages\/)?([\w-]+)`)
var str = `https://www.facebook.com/abc-def-12345678/
https://www.facebook.com/audi
https://www.facebook.com/pages/abc-def/1234568
https://www.facebook.com/audi/timeline?ref=page_internal`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}