using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.com\/(?:pages\/)?([\w-]+)";
string input = @"https://www.facebook.com/abc-def-12345678/
https://www.facebook.com/audi
https://www.facebook.com/pages/abc-def/1234568
https://www.facebook.com/audi/timeline?ref=page_internal";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}