#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((\d|\*(/\d{1,2})?)\s){5}http://www.\S+/.+doing_wp_cron\s>/dev/null\s2>&1$"
Local $sString = "*/30 * * * * http://www.testing.com/wp-cron.php?doing_wp_cron >/dev/null 2>&1" & @CRLF & _
"0 * * * * http://www.foo.test/bar.php?doing_wp_cron >/dev/null 2>&1" & @CRLF & _
"0 * * * * http://www.a.test/b.php?doing_wp_cron >/dev/null 2>&1" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")