import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((\\d|\\*(/\\d{1,2})?)\\s){5}http://www.\\S+/.+doing_wp_cron\\s>/dev/null\\s2>&1$";
final String string = "*/30 * * * * http://www.testing.com/wp-cron.php?doing_wp_cron >/dev/null 2>&1\n"
+ "0 * * * * http://www.foo.test/bar.php?doing_wp_cron >/dev/null 2>&1\n"
+ "0 * * * * http://www.a.test/b.php?doing_wp_cron >/dev/null 2>&1\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}