using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((\d|\*(/\d{1,2})?)\s){5}http://www.\S+/.+doing_wp_cron\s>/dev/null\s2>&1$";
string input = @"*/30 * * * * http://www.testing.com/wp-cron.php?doing_wp_cron >/dev/null 2>&1
0 * * * * http://www.foo.test/bar.php?doing_wp_cron >/dev/null 2>&1
0 * * * * http://www.a.test/b.php?doing_wp_cron >/dev/null 2>&1
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}