const regex = new RegExp('^((\\d|\\*(/\\d{1,2})?)\\s){5}http://www.\\S+/.+doing_wp_cron\\s>/dev/null\\s2>&1$', 'gm')
const str = `*/30 * * * * http://www.testing.com/wp-cron.php?doing_wp_cron >/dev/null 2>&1
0 * * * * http://www.foo.test/bar.php?doing_wp_cron >/dev/null 2>&1
0 * * * * http://www.a.test/b.php?doing_wp_cron >/dev/null 2>&1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}