re = /^((\d|\*(\/\d{1,2})?)\s){5}http:\/\/www.\S+\/.+doing_wp_cron\s>\/dev\/null\s2>&1$/m
str = '*/30 * * * * http://www.testing.com/wp-cron.php?doing_wp_cron >/dev/null 2>&1
0 * * * * http://www.foo.test/bar.php?doing_wp_cron >/dev/null 2>&1
0 * * * * http://www.a.test/b.php?doing_wp_cron >/dev/null 2>&1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end