// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((\d|\*(/\d{1,2})?)\s){5}http://www.\S+/.+doing_wp_cron\s>/dev/null\s2>&1$").unwrap();
let string = "*/30 * * * * http://www.testing.com/wp-cron.php?doing_wp_cron >/dev/null 2>&1
0 * * * * http://www.foo.test/bar.php?doing_wp_cron >/dev/null 2>&1
0 * * * * http://www.a.test/b.php?doing_wp_cron >/dev/null 2>&1
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}