# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[(\w{1,3})\](.*)\[\\/\1\]/<$1>$2<\/$1>/gmi;t' <<< "[b][b]test[/b][/b]
[b][a]test[/a][/b]
[b][b]test[/b]"