$re = '/\[(\w{1,3})\](.*)\[\/\1\]/mi';
$str = '[b][b]test[/b][/b]
[b][a]test[/a][/b]
[b][b]test[/b]';
$subst = "<$1>$2</$1>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;