#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)\[(\w{1,3})\](.*)\[\/\1\]"
Local $sString = "[b][b]test[/b][/b]" & @CRLF & _
"[b][a]test[/a][/b]" & @CRLF & _
"[b][b]test[/b]"
Local $sSubst = "<$1>$2</$1>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)