import Foundation
let pattern = #"\[(\w{1,3})\](.*)\[\/\1\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
[b][b]test[/b][/b]
[b][a]test[/a][/b]
[b][b]test[/b]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<$1>$2</$1>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)