use strict;
my $str = '[b][b]test[/b][/b]
[b][a]test[/a][/b]
[b][b]test[/b]';
my $regex = qr/\[(\w{1,3})\](.*)\[\/\1\]/mip;
my $subst = '<$1>$2</$1>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";