const regex = /\[(\w{1,3})\](.*)\[\/\1\]/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(\\w{1,3})\\](.*)\\[\\\/\\1\\]', 'gmi')
const str = `[b][b]test[/b][/b]
[b][a]test[/a][/b]
[b][b]test[/b]`;
const subst = `<$1>$2</$1>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);