# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/LINK\s*\(\s*([^\s,]+(?:\s[^\s,]+)*)\s*,\s*(\S+)\s*\)/<a class="inlinelink" target="blank" href="$2">$1<\/a>/;t' <<< "LINK( some anchor text , http://mydomain.com )"