import Foundation
let pattern = #"LINK\s*\(\s*([^\s,]+(?:\s[^\s,]+)*)\s*,\s*(\S+)\s*\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"LINK( some anchor text , http://mydomain.com )"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a class="inlinelink" target="blank" href="$2">$1</a>"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}