// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"LINK\s*\(\s*([^\s,]+(?:\s[^\s,]+)*)\s*,\s*(\S+)\s*\)").unwrap();
let string = "LINK( some anchor text , http://mydomain.com )";
let substitution = "<a class=\"inlinelink\" target=\"blank\" href=\"$2\">$1</a>";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}